Laborator 4. VLAN (Virtual LAN)

Cunoștințe și abilități ce vor fi dobândite

  • Ce sunt rețelele locale virtuale (Virtual Local Area Networks – VLAN)?
  • Tipuri de legături în VLAN-uri (access, trunk)
  • Configurarea VLAN-urilor în Cisco IOS

Cheat sheet

Exerciții

00. [5p] VLAN-uri în Cisco IOS

Rețelele locale virtuale (Virtual Local Area Networks – VLANs) sunt moduri de a realiza o separație logică a unei rețele locale (LAN) în mai multe subrețele pe aceeași infrastructură fizică. Separația este realizată la nivelul Legătură de Date prin introducerea unui câmp suplimentar în antetul de nivel 2. VLAN-urile sunt identificate în cadrul frame-ului printr-un VLAN ID.

Configurarea VLAN-urilor se realizează pe switch-uri, mai exact pe interfețele/porturile switch-urilor. Stațiile nu au cunoaștere despre existența unor VLAN-uri; perspectiva lor este aceea a unei rețele locale, adică rețeaua virtuală aferentă unui VLAN ID. O stație se va găsi în VLAN-ul specific portului la care este conectată (configurație existentă pe switch).

În topologia Packet Tracer de la această adresă stațiile PC0 și PC2 fac parte din VLAN-ul 10, iar stațiile PC1 și PC3 din VLAN-ul 20. Observați că pot comunica doar două câte două, deși adresele lor IP sunt din același spațiu de adrese.

Configurarea celor două VLAN-uri a fost realizată pe switch-ul Switch0. Pentru a investiga configurația de VLAN-uri de pe switch-ul Switch0, rulați comenzile de mai jos și urmăriți output-ul acestora. Pentru a accesa intefața de configurare a switch-ului, urmații pașii:

  1. Dați click pe switch.
  2. Accesați tab-ul CLI.
  3. Apăsați tasta Enter pentru a apărea promptul de transmitere de comenzi pentru switch.
  4. Folosiți comanda enable (urmată de apăsarea tastei Enter) pentru a accesa modul privilegiat de configurare a switch-ului.

Afișați configurația vlan-urilor.

Rezolvare
Comanda show vlan brief1) afișează informații despre VLAN-uri:
Switch0#show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa4/1, Fa5/1
10   zece                             active    Fa0/1, Fa2/1
20   douazeci                         active    Fa1/1, Fa3/1
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active  

Urmăriți că VLAN-ul cu ID-ul 10 (denumit și zece) conține porturile Fa0/1 și Fa2/1 adică porturile aferente stațiilor PC0 și PC2. La fel, VLAN-ul cu ID-ul 20 (denumit și douăzeci) conține porturile Fa1/1 și Fa3/1 adică porturile aferente stațiilor PC1 și PC3.

Rezolvare
Pentru a observa configurația curentă a switch-ului, folosiți comanda show running-config:
Switch0#show running-config
Building configuration...

Current configuration : 697 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch0
!
no ip domain-lookup
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet1/1
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet2/1
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet3/1
 switchport access vlan 20
 switchport mode access
!
[...]

Afisati configurația curentă. Din output-ul comenzii observați că porturile sunt configurate în modul acces în VLAN-urile respective.

Rezolvare
Comenzile switchport mode access respectiv switchport access VLAN <VLAN-ID> au fost rulate în modul de configurare a fiecărui port pentru a adăuga respectivul port la VLAN.

01. [10p] VLAN de management

În topologia Packet Tracer de la această adresă se află o rețea cu un switch (Switch0) și trei stații. Toate stațiile sunt conectate una la cealaltă și inclusiv la switch-ul Switch0 (și switch-ul are adresă IP).

În Cisco IOS primul pachet trimis poate să nu fie de fapt trimis din cauza absenței tabelei ARP. De aceea când trimiteți un pachet în Packet Tracer la sau de la switch, prima oară nu va funcționa. Următoarele pachete, însă, vor funcționa. Detalii aici.

În general un switch poate fi configurat direct în consola acestuia2) sau de la distanță conectându-vă la switch folosind comanda telnet urmată de adresa IP a acestuia. Conectați-vă la switch-ul Switch0 de pe fiecare dintre cele 3 stații urmând pașii:

  1. Dați click pe stație.
  2. Alegeți tab-ul Desktop.
  3. Dați click pe icon-ul Command prompt.
  4. Executați comanda telnet 192.168.1.254.
    • 192.168.1.254 este adresa IP a switch-ului.

Observați că vă puteți conecta la switch-ul Switch0 de pe oricare stație.

Dorim să securizăm accesul la switch-ul Switch0, permițând doar stației Management să se conecteze la acesta. Pentru acest lucru vom configura un nou VLAN, având ID-ul 100; din acest VLAN va face parte doar stația Management. Deseori acest VLAN poartă numele de VLAN de management.

Pentru a configura un VLAN pe un port al switch-ului, urmăm pașii:

  1. În consola de configurare activam modul privilegiat (folosiți parola student).
  2. Intrăm în modul de configurare.
  3. Creăm VLAN-ul cu ID-ul 100: vlan 100
    • Opțional putem configura și un nume pentru VLAN, să zicem management.
  4. Intrăm în modul de configurare al interfaței relevante.
  5. Configurăm interfața/portul pentru modul acces.
  6. Configurăm pe interfața de tip acces numărul VLAN-ului.
Rezolvare
Pentru a configura un VLAN pe un port al switch-ului, urmăm pașii:
  1. În consola de configurare rulăm comanda enable pentru activarea modului privilegiat (folosiți parola student).
  2. Intrăm în modul de configurare: configure terminal
  3. Creăm VLAN-ul cu ID-ul 100: vlan 100
    • Opțional putem configura și un nume pentru VLAN, să zicem management: name management
  4. Intrăm în modul de configurare al interfaței relevante: interface Fa0/1
  5. Configurăm interfața/portul pentru modul acces: switchport mode access
  6. Configurăm pe interfața de tip acces numărul VLAN-ului: switchport access vlan 100

Succesiunea completă de comenzi este cea de mai jos (folosiți parola student):

Switch0>enable
Password: 
Switch0#configure terminal
Switch0(config)#vlan 100
Switch0(config-vlan)#name management
Switch0(config-vlan)#exit
Switch0(config)#interface Fa0/1
Switch0(config-if)#switchport mode access 
Switch0(config-if)#switchport access vlan 100

În acest moment stația Management se află în VLAN-ul 100. Trebuie să configurăm și switch-ul pentru a răspunde cererilor de configurare tot pe VLAN-ul 100. Pentru a putea fi configurat corespunzător, unui switch i se pot crea interfețe virtuale de forma vlan X, unde X este numărul VLAN-ului de pe care poate fi accesat în vederea configurării. Interfața implicită pentru orice switch este vlan 1 pe care va trebui să o dezactivăm și să ștergem adresa. IP

Rezolvare
:
Switch0#configure terminal
Switch0(config)#interface vlan 1
Switch0(config-if)#shutdown
Switch0(config-if)#no ip address
Switch0(config-if)#exit

Vom configura adresa IP pe interfața vlan 100 aferentă VLAN-ului 100.

Rezolvare
Switch0(config)#interface vlan 100
Switch0(config-if)#no shutdown
Switch0(config-if)#ip address 192.168.1.254 255.255.255.0

După această configurare, switch-ul Switch0 va fi accesibil la adresa IP 192.168.1.254 doar de pe stația Management. Folosiți comanda telnet 192.168.1.254 din interfața CLI a fiecărei stații pentru a verifica faptul că vă puteți conecta sau nu la switch-ul Switch0. Observați că doar de pe stația Management poate fi realizată conectarea.

Conectivitatea între stații s-a păstrat. Nu a fost afectată de configurarea VLAN-ului de management.

02. [10p] Porturi în modul acces

În topologia Packet Tracer de la această adresă se află o rețea cu un switch, o stație de management și 4 stații (PC1, PC2, PC3, PC4) folosite de utilizatori. Observați că cele 4 stații pot comunica între ele fiecare cu fiecare.

Dorim să izolăm PC1 și PC3 de celelalte două stații (PC2 și PC4) astfel încât PC1 să poată comunica doar cu PC3. Acest lucru se poate realiza configurând porturile aferente lui PC1 și PC3 să facă parte din VLAN-ul 10, iar porturile aferente lui PC2 și PC4 să facă parte din VLAN-ul 20.

Rezolvare
Switch0>enable
Password: 
Switch0#configure terminal
Switch0(config)#vlan 10
Switch0(config-vlan)#name zece
Switch0(config-vlan)#exit
Switch0(config)#vlan 20
Switch0(config-vlan)#name douazeci
Switch0(config-vlan)#exit

Verificati adăugarea celor două VLAN-uri.

Rezolvare
prin rularea comenzii show vlan brief. Comanda poate fi rulată și din modul de configurare dacă este prefixată de comanda do:
Switch0(config)#do show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/1, Fa2/1, Fa3/1, Fa4/1
                                                Fa5/1, Fa6/1, Fa7/1
10   zece                             active    
20   douazeci                         active    
100  VLAN0100                         active    Fa0/1
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active

Se observă adăugarea celor două noi VLAN-uri: 10 și 20.

După ce am creat VLAN-urile în baza de date a switch-ului, trebuie să configurăm porturile să facă parte din acest VLAN-uri, după cum urmează:

  • Fa1/1 - PC1 - VLAN 10
  • Fa2/1 - PC2 - VLAN 20
  • Fa6/1 - PC3 - VLAN 10
  • Fa3/1 - PC4 - VLAN 20

Înainte de a fi configurate VLAN-urile porturile trebuie trecute în mod acces.

Rezolvare
Comenzile care trebuie rulate sunt cele de mai jos:
Switch0#configure terminal
Switch0(config)#interface fa1/1
Switch0(config-if)#switchport mode access
Switch0(config-if)#switchport access vlan 10
Switch0(config-if)#exit
Switch0(config)#interface fa2/1
Switch0(config-if)#switchport mode access
Switch0(config-if)#switchport access vlan 20
Switch0(config-if)#exit
Switch0(config)#interface fa6/1
Switch0(config-if)#switchport mode access
Switch0(config-if)#switchport access vlan 10
Switch0(config-if)#exit
Switch0(config)#interface fa3/1
Switch0(config-if)#switchport mode access
Switch0(config-if)#switchport access vlan 20
Switch0(config-if)#exit
Rezolvare
Verificati adăugarea porturilor în VLAN-uri, folosim, din nou, comanda show vlan brief:
Switch0(config)#do show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa4/1, Fa5/1, Fa7/1
10   zece                             active    Fa1/1, Fa6/1
20   douazeci                         active    Fa2/1, Fa3/1
100  VLAN0100                         active    Fa0/1
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    
Switch0(config)#

Verificați că VLAN-ul 10 conține porturile Fa1/1 și Fa6/1, iar VLAN-ul 20 conține porturile Fa2/1 și Fa3/1, așa cum am dorit.

Verificați conectivitatea între fiecare pereche de două stații. Observați faptul că doar stațiile din același VLAN pot să comunice între ele.

03. [15p] Subnetare și VLAN-uri

În topologia Packet Tracer de la această adresă am mai adăugat un switch (Switch1) la care au fost conectate alte 4 stații (PC5, PC6, PC7, PC8). Configurați switch-ul Switch1 astfel încât PC5 și PC7 să facă parte din VLAN-ul 10, iar celelalte 2 (PC6 și PC8) din VLAN-ul 20.

Împărțiți spațiul 172.16.234.96/27 în două subrețele de dimensiuni egale și configurați stațiile (PC1, PC3, PC5, PC7) din VLAN-ul 10 cu adrese IP din prima subrețea obținută, iar cele din VLAN-ul 20 (PC2, PC4, PC6, PC8) cu adrese IP din a doua subrețea.

Verificați conectivitatea între stațiile din același VLAN, două câte două, precizând de ce nu funcționează atunci când este cazul.

Nu verificați conectivitatea între două stații din switch-uri diferite întrucât între aceste switch-uri NU există legătură fizică.

04. [10p] Legătură de tip trunchi (trunk)

Pe topologia de la exercițiul 03. [15p] Subnetare și VLAN-uri, realizați o legătură de fibră între switch-urile Switch0 și Switch1 pe portul Fa4/1 al fiecărui switch. Testați conectivitatea între stații din același VLAN, dar switch-uri diferite. Observați că nu există conectivitate din cauză că nu există nici un mecanism activat prin care VLAN-urile de pe switch-uri diferite să comunice între ele.

Pentru a permite conectivitatea între stații aflate în același VLAN dar conectate switchuri diferite, trebuie să configurăm legătura dintre switch-uri în mod trunchi (trunk); această legătură permite încapsularea pachetelor cu VLAN-uri diferite. Identificați numărul portului de interconectare pe fiecare din switch-uri. Pe fiecare switch, intrați pe interfața aferentă și setați legătura în mod trunchi.

Pe switch-ul Switch0 configurați interfața Fa4/1 in mod trunk si permiteți accesul tuturor vlan-urilor.

Rezolvare
Switch0>enable
Password: 
Switch0#configure terminal
Switch0(config)#int fastEthernet 4/1
Switch0(config-if)#switchport mode trunk 
Switch0(config-if)#switchport trunk allowed vlan all 
Switch0(config-if)#

Pe switch-ul Switch1 configurați interfața Fa4/1 în mod trunk si permiteti accesul tuturor vlan-urilor.

Rezolvare
:
Switch1>enable
Password: 
Switch1#configure terminal
Switch1(config)#int fastEthernet 4/1
Switch1(config-if)#switchport mode trunk 
Switch1(config-if)#switchport trunk allowed vlan all 
Switch1(config-if)#

Investigați configurația de tip trunk pe ambele switch-uri.

Rezolvare
prin rularea comenzii show interfaces trunk pe ambele switch-uri:
Switch0#show interfaces trunk
Port        Mode         Encapsulation  Status        Native vlan
Fa4/1       on           802.1q         trunking      1

Port        Vlans allowed on trunk
Fa4/1       1-1005

Port        Vlans allowed and active in management domain
Fa4/1       1,10,20,100

Port        Vlans in spanning tree forwarding state and not pruned
Fa4/1       1,10,20,100
Switch0#

Switch1#show interfaces trunk 
Port        Mode         Encapsulation  Status        Native vlan
Fa4/1       on           802.1q         trunking      1

Port        Vlans allowed on trunk
Fa4/1       1-1005

Port        Vlans allowed and active in management domain
Fa4/1       1,10,20

Port        Vlans in spanning tree forwarding state and not pruned
Fa4/1       1,10,20
Switch1#

Se observă că interfața Fa4/1 este o interfață de tip trunk care transportă VLAN-urile 1 (cel implicit), 10 și 20. În cazul switch-ului Switch0 transferă și VLAN-ul de management (100). Aceasta se întâmplă întrucât ultimul argument al comenzii switchport trunk … a fost all, reprezentând toate VLAN-urile.

Verificați că stațiile din același VLAN pot comunica între ele indiferent de switch-ul la care sunt interconectate.

05. [20p] Extindere VLAN de management

În topologia configurată la 04. [10p] Legătură de tip trunchi (trunk) dorim să putem configura și switch-ul Switch1 de pe stația Management. Adică switch-ul Switch1 trebuie să fie accesat prin telnet de pe stația Management.

Pentru aceasta configurați adresa IP 192.168.1.252 pe switch-ul Switch1 pe interfața aferentă VLAN-ului de management (vlan 100).

Trebuie să creați VLAN-ul 100. Nu este suficient să configurați interfața aferentă (vlan 100).

Testați prin conectarea prin telnet de pe stația Management la Switch1.

Salvați topologia rezolvată dacă vreți să faceți exercițiile bonus, vă va trebui! ;)

06. [15p] Configurare legături de tip trunchi cascadate

Ne propunem să construim rețele locale virtuale (VLAN-uri) pe o topologie cu mai multe switch-uri. Vom folosi legături de tip trunchi între switch-uri.

Topologia PacketTracer de la această adresă conține 4 stații (PC0, PC1, PC2, PC3) și trei switch-uri (Switch0, Switch1, Switch2).

Cele patru stații au deja adresele IP configurate și trebuie să se găsească două câte două în VLAN-uri:

  • VLAN 10: PC0 și PC2
  • VLAN 20: PC1 și PC3

Pentru început, după ce switch-urile rulează STP, verificați conectivitatea între toate cele patru stații. Nefiind realizate configurații de VLAN pe switch-uri, stațiile pot comunica între ele, oricare două.

Configurați switch-urile astfel încât stațiile să poată comunica doar în cadrul VLAN-ului propriu (să existe separație la nivelul 2). Verificați transmițând pachete între oricare două stații.

Rezolvare
Procesul de configurare pe switch-ul Switch0 este următorul:
Switch0>en
Switch0#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch1(config)#vlan 10
Switch1(config-vlan)#name zece
Switch1(config-vlan)#exit
Switch1(config)#vlan 20
Switch1(config-vlan)#name douazeci
Switch1(config-vlan)#exit
Switch0(config)# int fa0/1
Switch0(config-if)#switchport mode access
Switch0(config-if)#switchport access vlan 10
Switch0(config-if)#exit
Switch0(config)# int fa1/1
Switch0(config-if)#switchport mode access
Switch0(config-if)#switchport access vlan 20
Switch0(config-if)#exit
Switch0(config)#int fa2/1
Switch0(config-if)#switchport mode trunk
Switch0(config-if)#switchport trunk allowed vlan 10,20
Switch0(config)#

Procesul de configurare pe switch-ul Switch1 este următorul:

Switch1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch1(config)#vlan 10
Switch1(config-vlan)#name zece
Switch1(config-vlan)#exit
Switch1(config)#vlan 20
Switch1(config-vlan)#name douazeci
Switch1(config-vlan)#exit
Switch1(config)#int fa0/1
Switch1(config-if)#swith
Switch1(config-if)#switchport mode trunk
Switch1(config-if)#switchport trunk allowed vlan 10,20
Switch1(config-if)#exit
Switch1(config)#int fa1/1
Switch1(config-if)#switchport mode trunk
Switch1(config-if)#switchport trunk allowed vlan 10,20
Switch1(config-if)#exit
Switch1(config)#

Procesul de configurare pe switch-ul Switch2 este următorul:

Switch2>en
Switch2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch2(config)#vlan 10
Switch2(config-vlan)#name zece
Switch2(config-vlan)#exit
Switch2(config)#vlan 20
Switch2(config-vlan)#name douazeci
Switch2(config-vlan)#exit
Switch2(config)#int fa1/1
Switch2(config-if)#switchport mode access
Switch2(config-if)#switchport access vlan 10
Switch2(config-if)#exit
Switch2(config)#int fa2/1
Switch2(config-if)#switchport mode access
Switch2(config-if)#switchport access vlan 20
Switch2(config-if)#exit
Switch2(config)#int fa0/1
Switch2(config-if)#switchport mode trunk
Switch2(config-if)#switchport trunk all
Switch2(config-if)#switchport trunk allowed vlan 10,20
Switch2(config-if)#exit
Switch2(config)#

07. [15p] Depanare probleme în lucrul cu VLAN-uri

Ne propunem să discutăm despre cum depanăm problemele în lucrul cu VLAN-uri.

Topologia Packet Tracer de la această adresă conține cinci stații care se găsesc în două VLAN-uri, astfel:

  • stațiile PC0, PC1 și PC3 se găsesc în VLAN-ul 10
  • stațiile PC2, PC4 se găsesc în VLAN-ul 20

Pentru început verificați de ce nu există conectivitate între stațiile PC0 și PC1 deși se găsesc în același switch. Investigați porturile switch-ului Switch0.

Apoi verificați de ce nu există conectivitate între stațiile PC2 și PC4. Investigați configurația pentru VLAN-ul de tip trunchi de pe switch-ul Switch1.

Pentru depanare urmăriți configurația curentă a switch-ului cu ajutorul comenzii

show running-config

Nu există conectivitate între stația PC0 și stația PC1 pentru că, în configurația switch-ului Switch0, stația PC1 este în VLAN-ul 20, în loc să fie în VLAN-ul 10. Reparați problema.

Rezolvare
Situația se rezolvă cu ajutorul comenzilor de mai jos:
Switch0>en
Switch0#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch0(config)#int fa 1/1
Switch0(config-if)#switchport access vlan 10
Switch0(config-if)#

Se așteaptă rularea STP și apoi va exista conectivitate între stația PC0 și stația PC1.

Nu există conectivitate între stația PC2 și stația PC4 pentru că, în configurația switch-ului Switch1, se permite pe legătura de tip trunchi doar VLAN-ul 10. Reparați problema.

Rezolvare
Pentru a permite și VLAN-ul 20, aferent stațiilor PC2 și PC4, se rulează comenzile:
Switch1>en
Switch1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch1(config)#int fa3/1
Switch1(config-if)#switchport trunk allowed vlan 10,20
Switch1(config-if)#

După configurarea corecta de mai sus, va exista conectivitate între stația PC0 și stația PC1.

08. [BONUS - 10p] VLAN nativ

Vom lucra cu noțiunea de VLAN nativ, care permite transferul fără tag VLAN într-o legătură de tip trunchi.

Folosiți topologia de la 05. [20p] Extindere VLAN de management. Urmăriți formatul cadrelor transmise între stații din VLAN-ul 10 conectate la switch-uri diferite.

Configurați apoi VLAN-ul 10 ca VLAN nativ pentru legătura trunchi dintre Switch0 și Switch1 și urmăriți din nou cadrele transmise între stații din VLAN-ul 10 conectate la switch-uri diferite. Dacă ați realizat configurația corectă, cadrele nu vor avea tag VLAN (dot1q), fiind vorba de VLAN-ul nativ.

Puteți urmări formatul cadrelor în modul Simulation din Packet Tracer.

Pentru documentație legată de configurarea unui VLAN nativ, urmăriți această secțiune.

Rezolvare
Configurarea pentru Switch0:
Switch0# configure terminal
Switch0(config)# interface fa4/1
Switch0(config-if)# switchport trunk native vlan 10

09. [BONUS - 10p] Filtrare VLAN-uri pe legătura de tip trunchi

Folosiți topologia de la 05. [20p] Extindere VLAN de management și configurați legătura de tip trunchi între switch-ul Switch0 și Switch1 să nu permită încapsularea pachetelor din VLAN-ul 20; adică pachetele din VLAN-ul 20 să nu mai fie trimise pe legătura de trunchi. Astfel stațiile din VLAN-ul 20 conectate la switch-ul Switch0 nu mai pot comunica cu cele din VLAN-ul 20 conectate la switch-ul Switch1. Stația Management trebuie să poată în continuare să acceseze Switch1, iar stațiile din VLAN-ul 10 să poată comunica indiferent de switch-ul la care sunt conectate.

Pentru documentație legată de configurarea VLAN-urilor permise, urmăriți această secțiune.

Rezolvare
Configurare pentru Switch0:
Switch0# configure terminal
Switch0(config)# interface fa3/1
Switch0(config-if)# switchport trunk allow vlan 10,100
2) dați click pe el și selectați tab-ul CLI
rl/labs/04.txt · Last modified: 2020/01/09 17:19 by octavian.grigorescu
CC Attribution-Share Alike 3.0 Unported
www.chimeric.de Valid CSS Driven by DokuWiki do yourself a favour and use a real browser - get firefox!! Recent changes RSS feed Valid XHTML 1.0