Laboratorul 04. OSPF (2)

Motivaţie

După ce v-ați familiarizat cu comportamentul de bază al protocolului OSPF, sunteți provocați să implementați politici avansate ale protocolului folosind tipuri speciale de arii OSPF prin care să eficientizați tabelele de rutare în rețea.

Topologie

Cheatsheet

Cerințe

Intre echipamentele din laborator, exista deja OSPF multi area configurat, conform topologiei din imagine. Pentru a conecta aria 2 de aria 0, s-a folosit un virtual link, creat intre R2 si R3. Nu începeți taskurile acestui laborator fără să încărcați initial_configs.

Resurse Laborator

  • Descărcați configurațiile, topologia și imaginea de OS de aici

Exerciții

01. [5p] Arie stub

Trebuie să configurăm area 1 prezentă pe R2, R3 și R4 ca arie de stub care filtrează update-urile de tip 5 External Link și de tip 4 ASBR Summary primite din area 0. Care este problema de care vă loviți?

Afișează rezolvarea
Ascunde rezolvarea
Afișează rezolvarea
Aflăm procesul de OSPF care rulează pe fiecare ruter astfel:
R1(config)#do sh ip proto | include ospf
Routing Protocol is "ospf 1"
R2(config)#router ospf 1
R2(config-router)#area 1 stub
% OSPF: Area cannot be a stub as it contains a virtual link

Pe R2 și R3 nu putem configura area 1 ca stub deoarece a fost folosită pentru configurarea unui virtual link. Adiacențele dintre R2 și R4, respectiv dintre R3 și R4 vor pica deoarece pentru formarea adiacențelor OSPF trebuie să coincidă bitul de stub.

02. [20p] Tunel GRE

Pentru a putea configura aria 1 ca arie specială OSPF, elimitați virtual link-ul dintre R2 si R3 si inlocuiti-l cu un tunel GRE intre R2 si R3

Afișează rezolvarea
Ascunde rezolvarea
Afișează rezolvarea
Ștergerea configurării de virtual link:
R3(config-router)#do sh run | section router ospf
router ospf 1
[...]
area 1 virtual-link 150.1.6.1
[...]
R3(config-router)#no area 1 virtual-link 150.1.6.1
R2(config-router)#do sh run | section router ospf
router ospf 1
[...]
area 1 virtual-link 150.1.3.1
[...]
R2(config-router)#no area 1 virtual-link 150.1.3.1

Tunelare GRE:

R2(config)#interface Tunnel0
R2(config-if)# ip address 11.0.0.1 255.255.255.0
R2(config-if)# ip ospf 1 area 0
R2(config-if)# tunnel source FastEthernet0/0
R2(config-if)# tunnel destination 10.10.211.3
R3(config)#interface Tunnel0
R3(config-if)# ip address 11.0.0.2 255.255.255.0
R3(config-if)# ip ospf 1 area 0
R3(config-if)# tunnel source FastEthernet0/0
R3(config-if)# tunnel destination 10.10.211.6
R3(config-if)#do sh ip ospf neig

Neighbor ID     Pri   State          Dead Time   Address         Interface
150.1.6.1         0   FULL/  -       00:00:38    11.0.0.1        Tunnel0 [...]

03. [10p] Aria 1 specială

Odată ce ați obținut din nou conectivitate între aria 2 și aria 0, configurați aria 1 ca arie specială OSPF pentru a filtra rutele externe.

  • Rulați comanda sh ip route pe R3. Apar rute externe? De ce?
Afișează rezolvarea
Ascunde rezolvarea
Afișează rezolvarea
R2(config-if)#router ospf 1
R2(config-router)#area 1 stub
R3(config-if)#router ospf 1
R3(config-router)#area 1 stub

Aceste rute sunt aflate via Tunnel0, nu via FastEthernet0/0 din area 1 stub.

  • Afisați baza de date OSPF pe R3 și identificați de unde aveți rute externe în tabela de rutare OSPF.
Afișează rezolvarea
Ascunde rezolvarea
Afișează rezolvarea
R3(config-router)#do sh ip ospf database
[...]
#### Type 4 LSA
                Summary ASB Link States (Area 2) 

Link ID         ADV Router      Age         Seq#       Checksum
150.1.1.1       150.1.3.1       80          0x80000001 0x003931

                Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
0.0.0.0         150.1.1.1       495         0x80000001 0x00DA3E 1
150.1.1.1       150.1.1.1       495         0x80000001 0x00C0AC 0
150.1.3.1       150.1.3.1       493         0x80000001 0x0019D0 0

Atât pentru ruta externă 150.1.1.1, cât și pentru 0.0.0.0, introduse prin LSA de tip 5, advertising router este 150.1.1.1, adică R1. În secțiunea Summary ASB Link States dedicată LSA-urilor de tip 4, pe coloana Link ID avem ID-ul ASBR-ului care introduce rute de tip 5, iar pe coloana ADV Router avem ABR-ul care propaga Link State-uri de tip 5 din backbone area în area 2(listată în titlul secțiunii). Observăm că ABR-ul este 150.1.3.1, adică R3 care este conectat prin area de backbone prin Tunnel0.

04. [5p] Rute default

4. Afisați tabela de rutare pe R4.

Afișează rezolvarea
Ascunde rezolvarea
Afișează rezolvarea
Rogue#sh ip route
[...]
O*IA 0.0.0.0/0 [110/2] via 10.10.211.6, 00:18:46, FastEthernet0/0
               [110/2] via 10.10.211.3, 00:18:46, FastEthernet0/0
  • Câte rute default aveți? De ce?
Afișează rezolvarea
Ascunde rezolvarea
Afișează rezolvarea
Avem 2 rute, una prin ABR-ul R2 care e direct conectat la area 0, una prin ABR-ul R3 care e conectat la area 0 prin tunel. Rutele au metrici egale deoarece sunt rute de tip inter-area al căror cost se calculează ca sumă a costului rutei din punct de vedere al ABR-ului care o propagă inter-area, plus costul lui R4 până la ABR: Costurile lui R2 și R3 pentru ruta 0.0.0.0 sunt egale cu 1 chiar dacă R3 află despre 0.0.0.0 prin R2, deoarece 0.0.0.0 este redistribuită în area 0 ca rută de tip E2 (fără cost cumulativ) Costurile lui R4 până la R2 și R3 sunt egale cu 1

05. [15p] Rute externe cu cost cumulativ

Interfețele de Loopback de mai jos sunt deja configurate pe R4. Dorim sa introducem aceste retele în OSPF ca rute externe cu cost cumulativ si metrica de intrare 10:

  • Loopback1: 192.168.0.1/26
  • Loopback2: 192.168.0.65/26
  • Loopback3: 192.168.0.129/26
  • Loopback4: 192.168.0.193/26
  1. Functioneaza redistribuirea pe R4?

Modificati tipul ariei astefel incat sa permita introducerea de informatii externe si redistribuiti retelele.

  1. Cum arata acestea pe R1? Cu ce cod apar?

Pentru a modifica tipul ariei, trebuie mai intai sa stergeti tipul curent de arie si sa-l modificati pe cel nou.

R4(config)#router ospf 1
R4(config-router)#no area 1 stub
R4(config-router)#area 1 <new-type>
Afișează rezolvarea
Ascunde rezolvarea
Afișează rezolvarea
R2(config)#router ospf 1
R2(config-router)#no area 1 stub
R2(config-router)# area 1 nssa

R3(config)#router ospf 1
R3(config-router)#no area 1 stub
R3(config-router)# area 1 nssa


R4(config)#router ospf 1
R4(config-router)#no area 1 stub
R4(config-router)# area 1 nssa
R4(config-router)# redistrubute connected metric-type 1 metric 10 subnets

R1#sh ip route
[..]

     192.168.0.0/26 is subnetted, 4 subnets
O E1    192.168.0.64 [110/21] via 172.1.231.2, 00:00:35, Ethernet2/1
O E1    192.168.0.0 [110/21] via 172.1.231.2, 00:00:43, Ethernet2/1
O E1    192.168.0.192 [110/21] via 172.1.231.2, 00:00:16, Ethernet2/1
O E1    192.168.0.128 [110/21] via 172.1.231.2, 00:00:27, Ethernet2/1
[..]

06. [5p] Testare conectivitate

Afisați tabela de rutare pe R2. Cu ce cod cunoaște acest ruter rețelele 150.1.3.1 și 150.1.4.1? Testați conectivitatea către 150.1.4.1 de pe un ruter din rețea (diferit de R4)

Afișează rezolvarea
Ascunde rezolvarea
Afișează rezolvarea
150.1.3.1 - Loopback R3 150.1.4.1 - Loopback R4
R1#sh ip route
[...]
O N2 150.1.4.1 [110/40] via 10.10.211.1, 00:02:32, FastEthernet0/0
O N1 150.1.3.1 [110/21] via 10.10.211.3, 00:02:32, FastEthernet0/0
R4(config)#do ping 150.1.4.1
[...]
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/25/44 ms

Codul care apare indică o rută de tip E2, respectiv E1 redistribuită într-o arie care este NSSA.

07. [10p] Interfața Lo0 inaccesibilă

Deși ați rezolvat cu succes și această problemă, acum utilizatorii se plâng de faptul că ruterul R4 nu mai oferă acces la interfata Lo0 a ruterului R1 (IP-ul 150.1.1.1). Reteaua respectiva a fost adaugata pe R1 prin redistribuire. Care este cauza acestei probleme?

Configurați rețeaua astfel încât toate ruterele din aria 1 să primească o rută default de la R2, fără a schimba tipul de arie.

Afișează rezolvarea
Ascunde rezolvarea
Afișează rezolvarea
Cauza problemei este că în arii de tip NSSA, spre deosebire de arii de stub, ABR-ul (fie el R2 sau R3) nu distribuie rute default în mod implicit.
R4(config-router)#do ping 150.1.1.1
[...]
.....
Success rate is 0 percent (0/5)
R4(config-router)#do sh ip route
[...]
O*N2 0.0.0.0/0 [110/1] via 10.10.211.6, 00:00:15, FastEthernet0/0
Rogue(config-router)#do ping 150.1.1.1
[...]
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/25/72 ms
R2(config)#router ospf 1
R2(config-router)#area 1 nssa default-information-originate

08. [10p] OSPF Aria 201

Configurați interfețele de Loopback de mai jos pe R2 și introduceți aceste rețele în OSPF aria 201:

  • Loopback1: 192.168.1.1/25
  • Loopback2: 192.168.1.129/25
Afișează rezolvarea
Ascunde rezolvarea
Afișează rezolvarea
R2#sh ip proto
[..]
    192.168.1.1 0.0.0.0 area 201
    192.168.1.129 0.0.0.0 area 201
[..]
R2(config)#interface Loopback1
R2(config-if)# ip address 192.168.1.1 255.255.255.128
R2(config-if)#interface Loopback2
R2(config-if)# ip address 192.168.1.129 255.255.255.128
R2(config-if)#router ospf 1
R2(config-router)# network 192.168.1.1 0.0.0.0 area 201
R2(config-router)# network 192.168.1.129 0.0.0.0 area 201

09. [10p] Sumarizare rețele

Sumarizați rețelele de loopback(Lo1, Lo2, Lo3, Lo4) ale lui R4 pentru a introduce o singură rută în OSPF. Verificați comportamentul în tabelele de rutare ale ruterelor vecine.

Afișează rezolvarea
Ascunde rezolvarea
Afișează rezolvarea
R4(config-if)#router ospf 1
R4(config-router)#summary-address 192.168.0.0 255.255.255.0
R1#sh ip route
[...]
O E2 192.168.0.0/24 [110/40] via 10.10.211.1, 00:00:08, FastEthernet0/0
[...]

10. [10p] Sumarizare rețele 2

Sumarizați rețelele de loopback ale lui R2 pentru a introduce o singură rută în OSPF. Verificați comportamentul în tabelele de rutare ale ruterelor vecine.

Afișează rezolvarea
Ascunde rezolvarea
Afișează rezolvarea
R2(config-router)# area 201 range 192.168.1.0 255.255.255.0
Rogue(config-router)#do sh ip route
[...]
O IA 192.168.1.0/24 [110/2] via 10.10.211.6, 00:00:47, FastEthernet0/0
[...]

11. [BONUS - 10p] Redistribuire rute statice

Adăugați interfața Loopback1 pe R5 cu adresa 192.168.100.1/24. Introduceți această rețea în OSPF fără a da nici o comandă OSPF pe ruterul R5.

Hint: Redistribuire de rute statice

Afișează rezolvarea
Ascunde rezolvarea
Afișează rezolvarea
R5(config)#int lo1
R5(config-if)#ip addr 192.168.100.1 255.255.255.0
R3(config)#ip route 192.168.100.0 255.255.255.0 10.10.211.169
R3(config)#router ospf 1
R3(config-router)#redistribute static subnets
pr/labs/04.txt · Last modified: 2019/10/29 12:49 by octavian.grigorescu
CC Attribution-Share Alike 3.0 Unported
www.chimeric.de Valid CSS Driven by DokuWiki do yourself a favour and use a real browser - get firefox!! Recent changes RSS feed Valid XHTML 1.0