Laboratorul 03. OSPF

Motivație

După achiziționarea unui nou sediu vă confruntați cu provocarea configurării protocolului OSPF. Pentru că doriți să asigurați o implementare scalabilă ați ales implementarea Multi-Area OSPF.

Topologie

Resurse laborator

  • Descărcați configurațiile inițiale de aici
  • Descărcați fișierul de topologie de aici
  • Arhivă imagine OS c3640-js.bin.zip

Exerciții

01. [15p] OSPF 1 aria 0

Configurati OSPF 1 aria 0 intre ruterele R1, R2 si R3, pe segmentele R1-R2, R1-R3 si R2-R3.

R1(config)#interface e2/1
R1(config-if)#ip ospf 1 area 0
R1(config)#interface e2/2
R1(config-if)#ip ospf 1 area 0

R2(config)#interface e2/1
R2(config-if)#ip ospf 1 area 0
R2(config)#interface e1/0
R2(config-if)#ip ospf 1 area 0

R3(config)#interface e1/0
R3(config-if)#ip ospf 1 area 0
R3(config)#interface e2/2
R3(config-if)#ip ospf 1 area 0

#show ip ospf neighbor

02. [15p] OSPF 1 aria 2

Configurați OSPF 1 aria 2 între ruterele R1, R4 și R5.

R1(config)#interface Fa1/0
R1(config-if)#ip ospf 1 area 2

R4(config)#interface Fa2/0
R4(config-if)#ip ospf 1 area 2

R5(config)#interface Fa1/0
R5(config-if)#ip ospf 1 area 2

#show ip ospf neighbor

03. [15p] Modificare OSPF DR, BDR

Reconfigurați cele 3 rutere de pe segmentul ariei 2, astfel încât ruterul care este în acest moment în starea DROTHER, să devină BDR, iar ruterul care este în acest moment BDR, să devină DR.

R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1

R4(config)#router ospf 1
R4(config-router)#router-id 4.4.4.4

R5(config)#router ospf 1
R5(config-router)#router-id 5.5.5.5

#clear ip ospf process

04. [15p] Probleme de adiacență

Pe segmentul între R3 și R4, administratorul care s-a ocupat anterior de rețea a configurat unii parametri incompatibili pentru adiacența OSPF. Activați OSPF 1 aria 1 între cele 2 rutere și rezolvați problemele de adiacență astfel încât cele 2 rutere să ajungă in starea FULL de adiacență. După ce ați activat OSPF, folosiți comanda debug ip ospf events pe R4 pentru a găsi greșelile.

RR #debug ip ospf events
RR #undebug all

R3(config)#interface e2/1
R3(config-if)#ip ospf hello-interval 10
R3(config-if)#ip ospf dead-interval 40
R3(config-if)#ip add 10.34.0.1 255.255.255.252

05. [10p] Modificare rută

Modificați costul legăturii R4-R1, astfel încât pachetele care pleacă de la R4 câtre interfața e2/2 a lui R1 să meargă pe calea R4-R3-R1.

R4#traceroute 10.13.0.1
pachetele se duc pe interfata prin switch
R4(config)#interface Fa2/0
R4(config)#ip ospf cost 100
R4#traceroute 10.13.0.1
pachetele se duc pe interfata buna

06. [15p] Redistribuire rețele loopback

Pe R5, sunt configurate 4 interfețe de loopback. Adăugați în OSPF rețelele de pe aceste interfețe prin redistribuire. Verificați prezența lor în tabela de rutare de pe R1.

R5(config)#router ospf 1
R5(config-router)#redistribute connected subnets

07. [15p] Autentificare MD5

Configurați în OSPF autentificare MD5 între R3 și R4. Verificați că transmiterea update-urilor se face după verificarea cheii.

R4(config)#interface e1/0
R4(config-if)#ip ospf authentication message-digest
R4(config-if)#ip ospf authentication-key cisco

R3(config)#interface e2/1
R3(config-if)#ip ospf authentication message-digest
R3(config-if)#ip ospf authentication-key cisco

#debug ip ospf adj
#debug ip ospf packet

08. [BONUS - 10p] Detalii echipament

Considerând că R2 este legătura către internet, adăugați pe R2 în procesul OSPF o rută default, care să ajungă la vecinii lui. Verificați ruta default prin transmiterea de pachete ICMP(ping) de la R4 catre IP-ul 157.1.1.1.

R2(config)#router ospf 1
R2(config-router)#default0information originate always
pr/labs/03.txt · Last modified: 2019/10/29 12:51 by octavian.grigorescu
CC Attribution-Share Alike 3.0 Unported
www.chimeric.de Valid CSS Driven by DokuWiki do yourself a favour and use a real browser - get firefox!! Recent changes RSS feed Valid XHTML 1.0