Laboratorul 02. IPv6

Motivație

Odată cu expansiunea companiei, ați fost numit manager al Departamentului de Research and Development. Tema de cercetare presupune monitorizarea și măsurarea performanțelor unei rețele IPv6 peste o infrastructură IPv4. Pentru a putea avea o bază pentru măsurătorile dorite, va trebui să realizați configurațiile pentru infrastructura de rețea de care aveți nevoie. Principala tehnologie de interconectare pe care o veți studia va fi tunelarea. Aveți de a face cu 3 „insule” IPv6 pe care trebuie să le conectați printr-un tunel manual MCT (Manually Configured Tunnel) si printr-un tunel automat (6to4)

Topologie

Resurse laborator

  • Descărcați configurațiile inițiale de aici
  • Descărcați fișierul de configurare de aici
  • Arhivă imagine OS c3640-js.bin.zip

SHOWSOLUTION

Cerințe

1. [10p] Deschideti toate echipamentele, inclusiv RX, care va juca rol de IPv4 cloud din topologia laboratorului. Pe ruterele R1 si R2, adresele IPv4 au fost deja configurate. Verificati ca ping-ul functioneaza intre cele 2 echipamente.

Afișează rezolvarea
Ascunde rezolvarea
Afișează rezolvarea
R1#ping 172.14.31.2
!!!!!
R2#ping 172.1.231.2
!!!!!

2. [15p] Pe segmentul R2-R3, configurați adresa 3000::1/64 pe interfața s0/0 a lui R3. R2 va trebui să își autoconfigureze (stateless) pe s0/0 adresa IPv6.

Hint: Pentru autoconfigurare se folosesc mesajele de router advertisements primite de la R3.

Afișează rezolvarea
Ascunde rezolvarea
Afișează rezolvarea
R3(config)#ipv6 unicast-routing
R3(config)#interface s0/0
R3(config-if)#ipv6 address 3000::1/64
R3(config-if)#no shutdown
R3(config-if)#no ipv6 nd suppress-ra

R2(config)#interface s0/0
R2(config)#ipv6 address autoconfig

3. [15p] Pe interfetele Loopback0 ale lui R2 si R3 exista deja adrese IPv6 configurate. Adaugati RIPng pe segmentul dintre echipamente si pe interfetele de loopback, astfel incat sa functioneze ping-ul de la Lo0 a lui R2 la Lo0 a lui R3.

Afișează rezolvarea
Ascunde rezolvarea
Afișează rezolvarea
R2(config)#interface s0/0
R2(config-if)#ipv6 rip myrip enable
R2(config)#interface lo0
R2(config-if)#ipv6 rip myrip enable


R3(config)#ipv6 unicast-routing
R3(config)#interface s0/0
R3(config-if)#ipv6 rip myrip enable
R3(config)#interface lo0
R3(config-if)#ipv6 rip myrip enable

4. [15p] Intre R1 si R2 a fost creat un tunel MCT, dar ping-ul nu functioneaza intre interfetele de tunel. Reparati problema, folosind comanda #show running-config.

Afișează rezolvarea
Ascunde rezolvarea
Afișează rezolvarea
R1#show running-config | section tunnel0
interface Tunnel0
 no ip address
 ipv6 address 2000::2/64
 tunnel source Ethernet2/1
 tunnel destination 172.14.31.2
 tunnel mode ipv6ip

R2#show running-config | section tunnel0
interface Tunnel0
 no ip address
 ipv6 address 2000::1/64
 tunnel source FastEthernet3/0
 tunnel destination 172.1.231.2
 tunnel mode ipv6ip

5. [15p] Adaugati RIPng intre R1 si R2 pe interfetele de tunel.

Afișează rezolvarea
Ascunde rezolvarea
Afișează rezolvarea
R1(config)#interface tunnel0
R1(config-if)# ipv6 rip myrip enable

R2(config)#interface tunnel0
R2(config-if)# ipv6 rip myrip enable

6. [15p] Intre R1 si R4 a fost creat un tunel automat 6to4, dar ping-ul nu functioneaza intre interfetele de tunel. Reparati problema, folosind comanda #show running-config.

Afișează rezolvarea
Ascunde rezolvarea
Afișează rezolvarea
R1#show running-config
interface Tunnel2002
 no ip address
 no ip redirects
 ipv6 address 2002:AC01:E702::1/128
 tunnel source Ethernet2/1
 tunnel mode ipv6ip 6to4

ipv6 route 2002::/16 tunnel2002


R1#show running-config
interface Tunnel2002
 no ip address
 no ip redirects
 ipv6 address 
 tunnel source Ethernet2/1
 tunnel mode ipv6ip 6to4

ipv6 route 2002::/16 tunnel2002

R4#show running-config
interface Tunnel2002
 no ip address
 no ip redirects
 ipv6 address 2002:A0E:2::1/128
 tunnel source FastEthernet1/0
 tunnel mode ipv6ip 6to4

ipv6 route 2002::/16 tunnel2002

Bonus

R1 functioneaza ca un hub, ce conecteaza R4 de restul retelei. Pentru a putea conecta R4:

7. [5p] Injectați pe R1, in procesul RIPng, o ruta default, care sa ajunga la R2 si R3.

Afișează rezolvarea
Ascunde rezolvarea
Afișează rezolvarea
R1(config)#interface tunnel0
R1(config)#ipv6 rip myrip default-information originate

8. [5p] Adaugati, pe R4, o ruta default spre R1.

Ruta default pe interfata de tunel se adauga folosind IP next-hopului si NU interfata de iesire.

Afișează rezolvarea
Ascunde rezolvarea
Afișează rezolvarea
R4(config)#ipv6 route ::/0 2002:AC01:E702::1
pr/labs/02.txt · Last modified: 2019/11/11 14:45 by iulia.florea
CC Attribution-Share Alike 3.0 Unported
www.chimeric.de Valid CSS Driven by DokuWiki do yourself a favour and use a real browser - get firefox!! Recent changes RSS feed Valid XHTML 1.0